This topic contains 7 replies, has 2 voices, and was last updated by  Norman Medina 4 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1349 Reply

    Dave

    Hi Matt,

    I’m very interested in this plug-in (the paid version, but I need to get it to work first), but whatever I try, I can’t seem to get it to work.
    I have followed your documentation to the letter, entered the API key in the Options, but the Report list keeps saying:
    —-
    No Pagespeed Reports Found. Google Pagespeed may still be checking your pages. If problems persist, see the following possible solutions:
    Make sure that you have entered your Google API key on the Options page.
    Make sure that you have enabled “PageSpeed Insights API” from the Services page of the Google Console.
    The Google Pagespeed API may be temporarily unavailable.
    —-
    I have read the Troubleshooting post, tried some different options, but after waiting for over an hour nothing has changed!
    I hope you can help me.

    Dave

    #1353 Reply

    Matt Keys
    Keymaster

    Hey Dave,

    Sorry you are having troubles with the plugin, I would like to take a look and see what is happening that is causing it to not work on your server.

    Would it be possible for you to create a temporary user in your WordPress admin so that I can log in and see what is happening? If so, please use the contact form on this site to send me the login url and credentials.

    I have to go do some last-minute Christmas shopping today, but I should be back around later this evening to take a look.

    Thanks,

    Matt Keys

    #1641 Reply

    Matt Keys
    Keymaster

    To anyone else experiencing this issue. The problem in this case was that the WP Cron feature of wordpress was disabled in wp-config.php.

    It was disabled with a line that looked like: define(‘DISABLE_WP_CRON’, ‘true’);

    Changing this value to false, or removing the line, will allow the WP Cron to run again.

    #4020 Reply

    Renato

    Hi Matt,

    I had the free version of the Google Pagespeed Insights for WP and two days ago it was working pretty well.

    Then yesterday I purchased the premium version and it’s no longer working.

    The problem I’m having it’s the same this guys posted here.

    I tried to find the (‘DISABLE_WP_CRON’, ‘true’) in the wp-config.php, but there was nothing there.

    What can I do?

    Do you think you can help me?

    Thanks!

    Renato

    #4021 Reply

    Renato

    ah, I also tried all the scan options and all the 3 options suggested and nothing helped. 🙁

    #4031 Reply

    Matt Keys
    Keymaster

    For anyone reading this, the problem Renato was experiencing was solved by uninstalling and reinstalling the plugin.

    #7077 Reply

    Rob Bernstein

    Hi

    I have successfully installed the plugin on about 10 sites, which are successfully linked by MainWP.

    However there are 3 sites where I cannot make your plugin work:

    • on 2 sites: before I get to enter the Google API key, the process is running “Google Pagespeed Options cannot be changed while Pagespeed is running. Please wait until it has finished to make any changes.” The save keys never appear. I have deactivated ALL other plugins, as well as deleted and re-installed your plugin, without change. Database entries exist. There are no errors logged.
    • on 1 site: there is a conflict with MainWP: if I enable MainWP your plugin disappears. I have deactiavted all other plugins, and deleted reinstalled GPI. Database entries exist.

    Any other suggestions?
    Thx
    ROB

    #8102 Reply

    Norman Medina

    Good morning,

    I am having trouble getting the plugin to work as well. I have used the freebie version for awhile. I loved it. The reports are beautiful. Unfortunately at some point it stoped working. I’m not sure why it stoped working. Maybe an upgrade from WordPress? Or maybe changing to a different cacheing software? We are currently using WP-Rocket.

    I upgraded to Google Pagespeed Insights → Premium Edition hoping to get things going again. I still can’t get it going.

    I have checked wp-config.php, everything appears as expected there.

    Nothing is being generated in the “log” directory.

    I tried

    WP-Cron
    Ajax and
    Session Flush.

    Ajax works the best, but it stops at 1%

    Thanks for all your help in advance.

Viewing 8 posts - 1 through 8 (of 8 total)
Reply To: Can't get it to work
Your information: